Автор Тема: Обновление PostgreSQL-9.3 -> PostgreSQL-9.4  (Прочитано 946 раз)

0 Пользователей и 1 Гость просматривают эту тему.

shurutov

  • Боги форума
  • *****
  • Сообщений: 357
  • Бог, царь и генеральный секретать
    • Бредни сумасшедших
Обновление PostgreSQL-9.3 -> PostgreSQL-9.4
« : Июня 12, 2015, 10:02:12 »
Таки прошло в нештатном режиме, но это так - мелочи. Зато сделано. Однако.
Итак, как это было (создание нового кластера путем emerge --configure postgresql-9.4.<minor version> я опускаю, т.к. никаких подводных камней не обнаружено при выполнении данной процедуры).
1. eselect postgresql 9.4 (в противном случае все утиля будут от 9.3, что грустно);
2. проверка наличия конфигов (ссылок на оные) в PGDATAOLD (оне у меня куда-то испарились на момент запуска pg_upgrade) и PGDATANEW;
3. выясняняем, в куда установились бинари: equery f postgresql-9.{3,4}.<minor version>|grep bin;
4. стопим оба сервера (что, еще и команды приводить?! Вы вообще за каким бесом в эту тему приперлись?!);
5. и запускаем pg_upgrade, который после вышеуказанных манипуляций отработал без ошибок.
6. Стартуем 9.4 версию и запускаем ~postgres/{analyze_new_cluster.sh,delete_old_cluster.sh} от пользователя postgres, как было рекомендовано в выводе pg_upgrade.
Потом eix-sync, emerge -uDN world, emerge --depclean.
Ну вот как-то так.
С уважением,
Шурутов Михаил